My Dyson 360 Vis Nav is not working. The logo on the display is lit and nothing else. | Dyson Community
Solved

My Dyson 360 Vis Nav is not working. The logo on the display is lit and nothing else.

  • 16 March 2024
  • 1 reply
  • 47 views


Our latest software release for the Dyson 360 Vis Nav™ robot vacuum (RB03PR.01.08.001.3325). The robot was unable to update via the app to version RB03PR.01.08.002.4054. The connection with the application has been severed and we cannot connect again. For the second day, the robot's logo display is on and a slight noise is heard. Nothing else can be done. Clicking on the display with the logo does not happen. What to do?

icon

Best answer by Jack 18 March 2024, 14:18

View original

This topic was closed to comments. To ask a question, please create a new topic.

1 reply

Userlevel 6
Badge +8

Hi @tem.nikitin,

Welcome to the Dyson Community, and thanks for letting us know about this.

For support, you'll need to talk directly to our Dyson Customer Care experts in your region - they’ll run you through some simple diagnostic checks to help pinpoint the cause of the issue. If a repair or a replacement is needed, they should be able to organise this for you under your free 2-year Dyson guarantee.

So we can help resolve things as quickly as possible, please visit Dyson.com when you have your machine easily to hand, and click the round purple button to launch the Dyson Digital Assistant. Then click the agent icon in the bottom left corner of the chat window to start a conversation with our Customer Care team.

We'll look forward to speaking with you!