Filter light even with a replacement filter. V10. Help! | Dyson Community
Solved

Filter light even with a replacement filter. V10. Help!

  • 3 March 2023
  • 2 replies
  • 4174 views

The filter light on my vacuum kept flashing, so I ordered a new filter - it’s an Amazon knock off, but all the reviews said that it worked just fine. I just put it in and the same thing is happening… My vacuum also appears to not really be sucking anything up, Everything seems to be blowing out of and around it - I got it about a year ago but I don’t use it that much so I don’t think I could’ve broke it. I don’t know what to do!

icon

Best answer by Anonymous 4 March 2023, 12:40

View original

This topic was closed to comments. To ask a question, please create a new topic.

2 replies

I’d bet money on the Amazon knockoff being at fault. I’ve not had the best of luck with these. One worked great, when the other didn’t. My suspicion was the material used was too dense, causing the suction/machines seal to fault. You could try washing the filter, seeing if that fixes it. It might loosen up the material. 

The suction problem could be a blockage. Give this post a read. It might point you in the right direction. https://community.dyson.com/tips-and-tricks-48/keeping-your-vacuum-performing-at-its-best-775

Kirby. 

Userlevel 6
Badge +1

Giving the vacuum a general overhaul/clean. If you don’t think it’s the filter that causing the problem, try a process of elimination. Remove parts one at a time, checking if any of them are the cause. Pressing the trigger each time you do. It’s how I look for a blockage when the light appears on my V10. 

Their Pulsing noise / blockage | Dyson Community post will assist.