MyDyson App Not Recognizing My Device | Dyson Community

MyDyson App Not Recognizing My Device

  • 27 February 2024
  • 3 replies


Following the highly anticipated launch of the Dyson 360 Vis Nav in France last week, and after receiving it, I am encountering an issue: the MyDyson app does not recognize the device.

I have attempted to connect it using my iPhone, iPad, and even an Android smartphone to no avail. Despite the device clearly emitting a Bluetooth signal.

It seems the issue lies with the app. Are there others experiencing the same problem?

The only solution offered by customer support (which is, by the way, very poor) is to return the device for a replacement within one week. However, this likely won't resolve the issue since the device is emitting a Bluetooth signal, indicating that the problem stems from the app.

I find it unacceptable to sell such an expensive device and offer such subpar customer support. At this price range, Apple provides much better service. It's baffling.


Best answer by FrenchBaguette 29 February 2024, 16:27

View original

This topic was closed to comments. To ask a question, please create a new topic.

3 replies

Hey ! 


I’m in the exact same situation : just received my 360 vis nav in France, and the app won’t recognize the robot.


I tried everything and every help guide I found. I also confirmed that the robot is emitting a bluetooth signal (broadcasting it’s name + serial number) so that clearly does not look like to be a hardware fault. Also tried updating the firmware with the USB key just in case. 


I contacted Dyson’s support and frankly, the experience was deplorable: I was kept waiting for almost 30 minutes, only to be asked again and again to repeat the steps described in the FAQ (check that bluetooth is enabled, try and remove the robot from the charger, etc). In the end, the only solution offered was an exchange of the product, again, with a minimum wait of one week (the product was out of stock), which didn't seem to make any sense. For the moment I've refused this solution, because I don't think it has anything to do with a hardware problem... and the fact that there's someone else with exactly the same problem at the exact same time reinforces my opinion :) 


My 2 cents : This version of the robot is broadcasting “EU” in it’s name instead of UK/US/AU (other markets). I wouldn't be surprised if the app just hasn't been updated (last update almost 1 month ago on iPhone) and just doesn't recognize robots with "EU" in their name…


Hey ! 

I re-tried to add the robot today, and it now works. Looks like something has been updated on the app :)


Userlevel 6
Badge +9

Hi @FrenchBaguette,

Thank you for the update here, I’m glad to hear you’ve now been able to get your robot connected!

@baskfr - please can I ask you to try again when you have a moment? Hopefully you should now be able to connect.