V7 not charging | Dyson Community
Solved

V7 not charging

  • 20 February 2024
  • 4 replies
  • 263 views

I have read all the trouble-shooting and actioned what they say re blockages etc but still no luck!

V7 not running

No blockages in filters or tubes

When pull trigger blue light flashes 10 times then goes off

Plugged into charger and on at mains, no lights

Leave for an hour, no lights

Unplug and pull trigger, blue light flashes 10 times

Repeat process but with no change.

Anyone able to give me advice? Is it the mains connector cable? Battery does flash blue and no red light so assume it’s ok.

icon

Best answer by Jack 21 February 2024, 15:02

View original

4 replies

Userlevel 6
Badge +8

Hi @jameshillhouse,

Welcome to the Dyson Community, and thanks for letting us know about this. 

This sounds like an unusual issue, and to help pinpoint the cause we'll need our Customer Care experts to take you through some further troubleshooting checks when you have your Dyson V7™ vacuum easily to hand. If a replacement part or a repair is needed, they’ll be able to confirm if this is covered under your Dyson warranty.

Please visit Dyson.com and click the round purple button to launch the Dyson Digital Assistant. Then click the agent icon in the bottom left corner of the chat window to start a conversation with our Customer Care team.

We'll look forward to speaking with you!

Thanks Jack. When I did as suggested, unlike most Digital Assistants where you enter into a conversation, Dyson only gives you options to select from, with not option to expand on the issue. For example, through their process of elimination on account of the choices I was asked to commit to in order to progress, the result was that we need a new charger. What I wasn’t able to communicate was that the pin hole connection on the vacuum cleaner felt a little loose when the charger pin was inserted ie could it be that connection on the vacuum cleaner itself that is faulty rather than the charger? Basically I don’t want to buy a new charger and find it doesn’t resolve the issue!

Userlevel 6
Badge +8

Hi @jameshillhouse,

Thanks for coming back to us!

Just so I’m clear, did you use the automated chatbot menu options, or speak with a live agent via live chat? If you didn’t speak to an agent, you can use the the agent icon in the bottom left corner of the chat window to start a conversation with our Customer Care team - and would be able to articulate to them the issue you’re having with the positioning of the battery and charger pin.

 

I selected the “Chat with an agent” icon and nothing happened so I took it that I had to “Please follow the instructions above”

Thought that was odd ...will try again.

Many thanks

Reply