Siri shortcut timeout | Dyson Community

Siri shortcut timeout

After I upgraded the IOS to 15.4.1, my Siri shortcut for HP09 will be timeout. I try to remove dyson link app and reinstall it. Also I remove the Siri shortcut and re-create the Siri shortcut. It’s also timeout. May anyone know how to fix it ? 


Best answer by Charliebrown 4 May 2022, 09:45

View original

This topic was closed to comments. To ask a question, please create a new topic.

6 replies

Have you tried following this post? 

I had a similar issue with Alexa. Where the commands wouldn’t work. It wasn’t after the recent update. I’d changed my internet provider and needed to update the password. I had to do this in the Dyson app and in the Alexa app. 

Not sure if the Siri app works the same as Alexa. 

Could updating have changed the passwords or settings somehow? 

Have you checked the release information for the iOS update? It might offer help in this area. 

Hello @Kenneth MK,

Thank you for visiting the Dyson Connected Community and posting your question. It would be unusual to hear that you’re having a time out issue, when trying to re-add the Siri shortcut back to your Dyson Link App. I presume that you’re still connected to the Dyson Link App, and are just having trouble with the Siri command controls? To reiterate what @Kibbleb mentioned, you may wish to check for an iOS update which may need to be performed. 

Also, have you disabled Auto mode prior to trying to add Siri commands again? This article may provide some further insight for you Connecting your Machine to Siri

If you still encounter issues, do let us know and we’ll be happy to assist you further.


Hi Kirby and Kelly,

I read the post you mention above but not able to solve it.

I even just try to kick the Siri shortcut instead of voice control and it’s time out as well.

I only try to set turn off control and turn off control. The Siri shortcut is time out also. 
Do I need to reset my HP09 ? And how ?




Userlevel 6
Badge +5

Hi @Kenneth MK 

Maybe I can help.. 

A few year ago I had almost an identical issue. On downloading and installing the latest OS my Siri Commands timed out. After what felt like hours troubleshooting on my own, I ended up contacted Apple Support. 

It turned out the issue was with my OS install and not any other App I was using. In the end I solved it but not before jumping through various stages.

I keep all the emails I send and receive from product Support. These come in really handy if I need to chase someone or have a similar issue in the future. Here is what they sent me.. 


In a later reply they asked me to test “Hey Siri”. The toggle under the enable setting reverted to off. 

I’d recommend checking this on your device. Setting>General>Siri >


This worked for me, but I am sure if it didn’t they would of had me reinstall the older version of the OS and redownload the latest one. 

If all this fails, I think Apple Support would be the next best option. It doesn’t sound like an issue with the Dyson app to me..

Apple Support - 

Good luck


Hi Charlie,

thanks your suggestion.

I finally solve the Siri shortcut timeout issue. I remove the existing HP09 from Dyson link App. I do it as new setup again. I create a new Siri shortcut and it’s solved now. 


Hi @Kenneth MK

Great news, we’re happy to hear that it’s working again for you. 

Best wishes,