V11 Cordless Absolute Vacuum - Power switching off/on | Dyson Community

V11 Cordless Absolute Vacuum - Power switching off/on

  • 1 November 2022
  • 4 replies

Userlevel 1

I have owned a V11 for 3 years and it has just started to give me problems.  It was initially cutting out and not charging, I followed the steps on the Dyson Support pages and concluded that I needed a new Main Body & Cyclone, which I purchased about 2 weeks ago.  Everything seemed fine for a week but was not charging correctly so I have replaced the battery only today.  It is not charging properly - the blue LEDs come on for approx 10 seconds then go off for approx 20 seconds then come back on for 10 seconds and this cycle just repeats itself.  I have removed it from the charging holster and plugged the charger into the V11 directly but it is still the same.  

Can anyone suggest what the problem might be?


(Edited by moderator – Tags added) 


Best answer by Jay 2 November 2022, 20:55

View original

4 replies

We gifted my mother-in-law a v11 for Christmas in 2018. 

She is very forgetful, so the onscreen notifications really help to reminder her when she has to perform general maintenance. My wife does still have to talk her through each step, sending her pictures from their website, otherwise she’d be lost.

In your case, I’ve checked the website, it still shows you’ll need a replacement Main Body & Cyclone.

Is it possible the parts you were sent are faulty?

I believe the failure rate on two of the exact same parts would be extremely low. 

As the Main Body & Cyclone contain the majority of the electrical components, it’s now more likely to be the battery or even the charger. 

It is plausible that all the components had a failure of some sort. You’d only solve it by ordering everything and returning what doesn’t fix it.


Userlevel 5
Badge +5

Hi there,

On my expectations, it seems that there’s an issue with the circuit board in the battery. As Dyson doesn’t provide repairs on the battery unit, it seems that the new battery unit would be needed. If it is still not resolved, you would need to check the charger at that point.


It seems that calling the Helpline or visiting a nearest service center would be the best option for you right now. As you’ve already purchased another part, I would suggest you to spend more money on that. Not sure what they will do, but call them and explain your situation. I am sure that they would do something to resolve.

Best wishes,


Userlevel 1


Thanks for everyone who got back to me.  The problem was the charger - I bought a new one and all is OK now.