Dyson robot can’t clean | Dyson Community

Dyson robot can’t clean

  • 29 November 2023
  • 3 replies

  • Novice Member
  • 2 replies

My robot cleaner is about 3 months old but as of 2 days ago, just won’t clean! It won’t do the scheduled clean. If I set up an app clean, it moves then immediately says returning to dock then I get a message saying Dyson can’t clean. 

I have a tried cleaning everything, powering down and turning back on to no avail. I can press the machine to clean, but only if not in the dock. Any tips welcome. It’s very frustrating!


Best answer by Anonymous 1 December 2023, 18:40

View original

This topic was closed to comments. To ask a question, please create a new topic.

3 replies

@cls Thanks for your post. That sounds like an odd software issue to me. Any software issue can be resolved by doing a full factory reset. Find out more about doing that here at this link:


Hi Adam

i actually deleted the map. When I looked at it, it was one tiny blob. Not sure how that came to be but deleting and creating the map again fixed it 

Hmm this problem persists. I’ll try the full reset