Comparing Dyson Models V7, V8, V10, V11, Outsize, Omni Glide, Micro, V12 Detect, and V15 Detect | Dyson Community
Sticky SPOTLIGHTED POST

Comparing Dyson Models V7, V8, V10, V11, Outsize, Omni Glide, Micro, V12 Detect, and V15 Detect

  • 23 October 2023
  • 2 replies
  • 4468 views

Userlevel 2
Badge +2

I read this post in the forums a few days back» 

 

And it mainly discusses the differences between the V6 and the V15 based on product specifications. As someone doing this for a living, I feel that there’s more nuance in comparing vacuums rather than just relying on manufacturer specifications.

For example, the post states that the run time of the V10 to V15 models is 60 minutes, which isn’t entirely accurate since the newer models use newer battery technology that runs further.

The V10, for instance, exceeded the 60 minute run time claim, but with the crevice tool. Stick a nozzle and that number goes down to around 41+ minutes give or take.

The V15 Detect ran for more than 80 minutes during my tests with the laser slim roller, and over 56 minutes with the standard nozzle in the lowest setting.

Power difference between the V8 and V10 isn’t as signifcant as the numbers suggest and this is backed up with the cleaning experiments.

I’ve tested all these products extensively » 

And here’s a post only my website » https://www.bestcordlessvacuumguide.com/best-dyson-vacuum/


This topic was closed to comments. To ask a question, please create a new topic.

2 replies

Userlevel 7
Badge +13

Hi @CordlessVacuumGuide

Thanks for sharing this with the community!

I can’t think of a better way to show this off than combining it with our ‘Spotlighted Post’ tag and pinning it to our General discussion | Cordless vacuums forum.

I’m sure these two steps will help it to stand out even more and that we’ll start to see more reviews like yours in no time 😀!!

If you’ve not already done so, I’d suggest visiting our Cordless vacuums | Knowledge Base and familiarising yourself with the content - if there’s anything you feel we’re missing, please let the team and I know.

Thanks,

Stuart

After washing the filter and replacing it a message ‘’ filter not sealed ‘’ keeps appearing?