filter not sealed after replacing a trigger | Dyson Community
Solved

filter not sealed after replacing a trigger

  • 15 April 2024
  • 1 reply
  • 70 views

Hi, i have a problem with my dyson v10. After replacing a trigger because it cracked, vacuum stopped working and shows filter not sealed on screen. I tried everything and it still doesn’t work any ideas?

icon

Best answer by Jack 17 April 2024, 12:29

View original

1 reply

Userlevel 6
Badge +8

Hi @Butla360,

Welcome to the Dyson Community!

As the repair to your machine hasn’t been completed by a Dyson service technician, it’s hard to guess at what the cause for this issue could be. It sounds like a component may have been damaged or reassembled slightly out of place, causing it not to recognise that the filter has been installed. But without the machine available to us, it would be hard for us to speculate.

All we can really recommend would be to make sure the filter is definitely fully rotated and locked in place, or to try either replacing the filter or the main body to see if that resolves things.

I’m sorry we’re not able to provide a more definite answer on this occasion.

Reply