V7 extra - suction issues! | Dyson Community
Solved

V7 extra - suction issues!

  • 27 November 2022
  • 1 reply
  • 157 views

I have the V7 extra. It charges fine, and was working fine. The roller was damaged (all the “teeth?!” had snapped off) so I bought a new one from Dyson. Since replacing, the roller spins fine, but the hoover seems to be sucking up far less. Really easy bits on the floor don’t get hoovered up. I’ve tried on both normal and extra mode.

 

Any ideas or suggestions? I’ve cleaned the filter, I’ve checked the roller is installed correctly (and it does roll fine when being used), and its fully charged.

 

(Edited by moderator – Tags added)

icon

Best answer by Anonymous 28 November 2022, 18:31

View original

This topic was closed to comments. To ask a question, please create a new topic.

1 reply

Hello @lrns88 

This sounds rather unusual to hear, that after changing the floor tool, you’ve noticed less suction. Having said that, it’s possible the suction issues were present before you swapped the head and you just need to go through some troubleshooting to locate a blockage causing the loss of pick-up. If you wanted to head directly to our online support, simple use our Guides and manuals link. Then select your machine from the options available and navigate through to the ‘Troubleshooting’ page. Here you will find a host of selectable options designed to support you and your machine.

 

Let us know what you find! We’re keen to help, if assistance is still needed.