anyone else having assistant issues like me | Dyson Community

anyone else having assistant issues like me

  • 4 January 2022
  • 3 replies
  • 296 views

So it was all fine and dandy before the Dyson major app redesign and update but now my tp01 devices for the most part no longer work with assistant consistently. 

I am very technical so if someone has a solution or knows the Dyson api handy perhaps I can quickly create my own app for my Google assisnt devices but what is happening is the same thing the new redisgned app has been doing since day one. Android devices here so maybe just an issues with Android but perhaps iOS as well. 

Anyways exactly like the app since it was redisgned i ask Google to make a change in a setting and it says trouble connecting right now please try again. 

This is about 70 percent of the time. I have done 35 relinks of my assistant account as well but I'm beginning to believe it is more on the iot side of things for Dyson because the app.

Ever since and it is currently up to date as of today the new redisgned app hit the scene a few months ago now we'll actually longer but you all know what I mean it has always or at least 70 percent if not higher higher of the time has always not been able to connect to many of my tp01 devices first time opening the app or opening the fn controls for a specific fan I want to adjust.

I own 16.What I have to do is if fan number 3 is what is shown upon opening the app as that was the last fan i changed a setting on it won't show that it is connected to the internet or can't connect to it so I have to switch to another fan or 2 and majority of the time switching to a other fan that new fan I just switched to will in fact be ok but then I have to go back to the not connected fan and that is what makes it come on line. Sometimes it takes 3 or 4 tries. When assistant says trouble and can't control device I open the app and the fan is not connect to internet. I then switch to another fan or 2 those usually populate then switch back to the fan in question and then it will connect. Sometimes it takes 2 or 3 tries. Once info that assistant works fine. 

(Edited by moderator – tags added)

Stuart 2 years ago

Hi @Armadous101 

Thanks for the follow up post.

It doesn’t seem we were able to answer this question the first time around. Sorry about that. 

Reading your initial post, it seems like there is a connection issue across some if not all of the machines you own; Hopefully the below information can help you troubleshoot the issues in your own time.

 

Connection

The Dyson App communicates with registered products by sending a ‘Hello Message’ when the app is initialised. This is processed through the Dyson cloud and based on the response it receives or lack of, it will either show the machine as Online or Offline.

If the App does not receive a reply to this message from a product, it will be shown as offline, which could indicate two things.

  1. The product is out of WiFi range or in a weak area of WiFi coverage to send and receive this message. Therefore, appearing offline. By switching back and forward multiple times, it is able to retrieve this data. To resolve this, I’d suggest following the advice on our ‘'Power Cycling/Restarting' your machine‘ article.
  2. The machine(s) may require a software update. If there are intermittent connection issues and the machine(s) are dropping off of Google Assistant, it could indicate a software version mismatch. Please make sure that the machine(s) have their Auto-update software toggled on. Read our ‘Viewing your machine's Software information’, article for instructions on how to enable this.

Furthermore, please ensure you are using a mobile device that meets the criteria set under our ‘App and Device compatibility’ article

 

Help with Google Assistant

There are several articles in the Knowledge Base that are designed to support users struggling with connection issues and their commands not being heard or recognised. These are hosted in our Google Assistant and Voice Assistant – Common questions sections.

I believe the following articles could also offer further guidance.

  1. Connecting your machine to a Google Assistant-enabled device
  2. Google Assistant didn't respond to my command, what can I do?
  3. Why don’t some of my commands work on Google Assistant?

If you need any further assistance, please feel free to @me in another response.

Thanks,

Stuart

View original

3 replies

Hi there,

Thank you for posting your question. It doesn’t seem that anyone else on the Community has experienced the same issue as you, which in itself is a good thing. However, does mean you’ve waited a little longer to get a reply. Having said that, the TP01 is not a connected device; can you confirm which Dyson model purifier you do have that you're trying to use with Google Assistant?

Not sure what you mean by it's not a connected device?

Userlevel 7
Badge +13

Hi @Armadous101 

Thanks for the follow up post.

It doesn’t seem we were able to answer this question the first time around. Sorry about that. 

Reading your initial post, it seems like there is a connection issue across some if not all of the machines you own; Hopefully the below information can help you troubleshoot the issues in your own time.

 

Connection

The Dyson App communicates with registered products by sending a ‘Hello Message’ when the app is initialised. This is processed through the Dyson cloud and based on the response it receives or lack of, it will either show the machine as Online or Offline.

If the App does not receive a reply to this message from a product, it will be shown as offline, which could indicate two things.

  1. The product is out of WiFi range or in a weak area of WiFi coverage to send and receive this message. Therefore, appearing offline. By switching back and forward multiple times, it is able to retrieve this data. To resolve this, I’d suggest following the advice on our ‘'Power Cycling/Restarting' your machine‘ article.
  2. The machine(s) may require a software update. If there are intermittent connection issues and the machine(s) are dropping off of Google Assistant, it could indicate a software version mismatch. Please make sure that the machine(s) have their Auto-update software toggled on. Read our ‘Viewing your machine's Software information’, article for instructions on how to enable this.

Furthermore, please ensure you are using a mobile device that meets the criteria set under our ‘App and Device compatibility’ article

 

Help with Google Assistant

There are several articles in the Knowledge Base that are designed to support users struggling with connection issues and their commands not being heard or recognised. These are hosted in our Google Assistant and Voice Assistant – Common questions sections.

I believe the following articles could also offer further guidance.

  1. Connecting your machine to a Google Assistant-enabled device
  2. Google Assistant didn't respond to my command, what can I do?
  3. Why don’t some of my commands work on Google Assistant?

If you need any further assistance, please feel free to @me in another response.

Thanks,

Stuart

Reply