New V15 and batter won't charge | Dyson Community
Question

New V15 and batter won't charge

  • 9 February 2024
  • 1 reply
  • 14 views

My V15 is under not even 6 months old and the battery seems dead.  I had left it in the machine with some battery power still available.  I tried to use it today and there was none.  I tried to charge it - no blue light goes on.  Any advice?  I have been super careful with this machine and love it!  I’m so disappointed right now...


1 reply

Userlevel 6

@tammygagliano  Thanks for your post, sorry to hear you’re having trouble with a power issue.
From your post, it’s not quite clear which part may be faulty. 
It could be either a charger, main body, or battery (or a power outlet, loose connection, etc. I’d recommend a guided troubleshooting here.

With your Dyson...

 

1. Please load up this guide page with your Dyson in hand :

 

Please follow the prompts and select the appropriate option on the bottom of each page. The guide will visually walk you through how to to resolve this.

 

https://www.dyson.co.uk/support/journey/troubleshooting/369372-01/power-or-electrical-issue-328910

If the steps above don't fix the issue, please contact local support.

Reply