Sorry, we can't connect to the Dyson network | Dyson Community

Sorry, we can't connect to the Dyson network

  • 25 October 2023
  • 6 replies

I changed phone and now each time I try to connect to my dyson account I got the following message:

“Sorry, we can't connect to the Dyson network, we are working to fix this. Please try again later”

This happen before I could even enter my password.

The support cannot help, they claim it should work. I created several new accounts, deleted and re-installed several time the app but it still does not work. It has been a month now and the pity is that I cannot change the schedule of the machine, since I need the app….

FYI, I have no VPN, etc… etc… If somebody could help, that would be much appreciated, this drives me crazy and it seems I am the only one having this issue (I could not find anything on the web).



Best answer by JamJam 30 October 2023, 11:53

View original

6 replies

@Lutryves Since you already uninstalled the app and your network hasn’t changed, the next step will be to factory-reset your Dyson purifier. This will remove all previous configurations, etc.
Since the process is different for each model, you may want to search for your model name and how to do a factory reset. That should do it.

I’m facing exactly this same problem. Since I changed to a new phone I’m not able to login in the Dyson Link app, and I’m not even asked for the password. I’ve tried to create a new account in the app, and I get the exact same message…

this has been happening for the past month, and I also can’t find any information or workaround to solve this problem. It really seems to be app related, and not with the devices, as my wife’s phone (which was also changed at the same time) has no issues to connect to that app and control the devices.


any tip on how to solve this is highly appreciated 

Userlevel 5

Have you downloaded the correct version of the App? You’ve referred to it as the Dyson Link App, where it’s now called the MyDyson App.

Userlevel 5

Here’s the post with the latest download links: Make sure the App is available in your country and hasn’t been removed from the store page. Downloading the Dyson App | Dyson Community.

If you’re still not getting any joy, reach out to Dyson directly. They’ve raise a ticket with IT for investigation. 

I am/was using the My Dyson app (as shown on the screen shot). I just re-installed it (there is apparently a newer version that is 1 week old) and still experiencing the same issue. I already contacted the Dyson support (several times), they do not help at all since they claim that it should work if I re-install the app (which I did several times) obviously without any success or if I create a new account (which I also did and guess what… does not work either).

My only workaround is now to use an old iPad which surprisingly and apparently has no problem to connect to my Dyson network (with my usual user id)…. I only use that iPad to control the schedule of my dyson device.

This is clearly an app related issue….and it is very very frustrating since it is going on since more than a month with no help from Dyson...

Just to let you know that today, by magic, it worked… I have changed nothing on my side so I guess Dyson must have changed something in the backend…. Although claiming everything was fine.