Scheduler Not Working - Dyson Hot+Cool Link | Dyson Community

Scheduler Not Working - Dyson Hot+Cool Link

  • 17 November 2023
  • 3 replies

  • Novice Member
  • 2 replies

I had a previously working schedule on my Hot+Cool Link. After the machine was unplugged for ~3 weeks whilst on holiday, the schedule has never worked since.


I’ve deleted the schedule and created a new one (with different settings).

Still no dice :(


Any ideas please?


Best answer by Anonymous 17 November 2023, 17:55

View original

This topic was closed to comments. To ask a question, please create a new topic.

3 replies

@JB81 Thanks for your post, I’d recommend removing your network settings from your HP02.

First delete and then reinstall the Dyson app on your phone.


Press and hold the ON/ OFF button on
the appliance for longer than 20 seconds.
NOTE: If you clear your network settings the appliance will not connect to the Dyson Link app. You will have to set up the network settings as if it’s a new device.

Thanks Adam.


I’ve followed these steps to a T and no luck.
I can remove the machine (after removing the App etc) but it won’t then let me re-add it, despite the machine being in Pairing Mode.

The *only* thing I can think of is that I have a Pi-Hole running as my DNS Server and potentially it might be blocking a call to one of the Dyson domains during the registration when it hands over from the HP02’s local network to my Wifi.

Do you know which domains are called during the registration please as if this is the problem, I could try and whitelist them


OK, no luck.
I’ve removed the PiHole from my network (just in case that was blocking the machine calling home).

I’ve created a brand new Dyson account on a different iPhone - this account sees the machine, but also can’t connect to it “We’re having trouble connecting...”

I’m not sure what other steps I can take here; there appears to be some fault in the machine’s Wifi as there’s nothing on my network preventing me adding this.

Is it worth attempting a warranty claim?